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Barometer Pairs using Jeff Smith’s SwissPairsScorer (v4.1.9) 

with Bridgemates II 
 

1. OVERVIEW 

 

1.1 Introduction 

SwissPairsScorer is easily adopted to score a barometer pairs event.  At the start of each 

round, the program performs the usual ‘Swiss’ draw assigning pairs to tables according to 

their current position in the event.  Once the program has made the draw for a round you 

manually edit the draw to produce the line-up you require for the movement in use. 

 

1.2 Program Constraints 

The program allows an event to consist of a number of sessions each of which consists of a 

number (need not be the same) of rounds 

The current program limits are: - 

• Min tables    3 

• Max sessions per event  12 

• Max rounds per event   40 

• Max boards per round   32 

• Max board no / boards per session 64 

 

1.3 Designing the event 

Obviously the limits described above play a large part in the overall competition design in 

terms of number of events, number of session in an event; rounds/session etc; all of which 

have implications for the duplication of boards. 

SBU Selection Committee have requested the following for two-day trials 

TablesTTables Rds Bds/rd Tot Bds Day1 Day 2 

3 5 (3,2) 20 100 60 40 

4 7 (4.3) 16 112 64 48 

5 9 (5,4) 14 126 70 56 

6 11 (6,5) 12 132 72 60 

  10 110 60 50 

7 13 (7,6) 10 130 70 60 

  8 104 56 48 

8 15 (8,7) 8 120 64 56 

9 17 (9,8) 8 136 72 64 

  6 102 54 48 

10 19 (10,9) 7 133 70 63 

  6 126 60 54 

Where the number of tables is odd (involves half-round arrow-switching) the number of 

bds/rd should be even. 

In a number of cases, two options are given (6, 7, 9, 10 tables); the entry in bold is preferred. 
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Notes: 

1. However you decide to set up the event, NEVER have a session which spans more 

than one day; ie, each day should see the start of a new session. 

2. Try and use as few sessions as possible (saves closing down BCS; exiting the event 
and then retrieving it at the start of the next session) - if number of boards in a day 

does not exceed 64, try to set up that day as one session.  However, if using the 

original bridgemates, I have a feeling that the max board no. is 63 – in some cases 

you may have to take that into account. 

3. In Appendix 1 there are suggested set-ups for all the requested scenarios. 
 

 

1.4 Scoring 

• The program allows for various scoring methods (X-imps and others) 

• Three X-IMP scoring methods are available: - 

� X-IMPs divided by comparisons 

� X-IMPs divided by sqrt(scores x comparisons/2) 

� X-IMPs raw total 

• If required any of the above can be converted in VPs by the program 

• Score input can either be manual or via bridgemates 

At any time, it is possible to change the score input method.  If a problem were to develop 

with the bridgemates then you can switch to manual input of scores– reassuring! 
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2. USING THE PROGRAM 
 

When you start SwissPairsScorer you are presented with the Main Menu. 

 

2.1 Creating an Event (illustrated with 8 tables playing 15 x 8 board rounds) 

From the Main Menu > Swiss Pairs Events.  You are taken to the Event History screen.  

Click the button Create New Event (bottom left) > Event Details 

Club Details 

Country Scotland 

Club Name S B U  

(Rest can be left blank) 

Event Details 

Event name Trials 

Date Date is selected automatically – can be changed if setting up in advance.  

Director & Scorer are optional – normally left blank; ignore P2P & NGS Rated 

BridgeWebs 

Leave blank 

 
 

Now click on Movement Details 
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Complete as shown below: - 

 
We have set up 2 sessions.  Session 1(day 1) playing 8 x 8 board rounds (bds 1-64) and 

session 2 (day 2) playing 7 x 8 board rounds (bds 1-56).  Each session starts with board 1 and 

scoring is in X-IMPS. Table Override is Unused. 

Click OK 

 

You are asked to confirm the movement details > Yes 

Message that Events 1 & 2 will be combined > OK 

Combined to multi-event 3 > OK 

You are now taken to the Event History screen: - 
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The screen shows 3 events.  Events 1 & 2 are sessions 1 & 2 resp. that we set up earlier. 

Event 3 is created by the program (it combines events 1 & 2) and is used from now on to 

control this event.  Usually known as the multi event. 

To continue, ensure event 3 is selected then click on Retrieve Event 

 

You are now presented with the Event Menu 

 

 

 

 

To enter names click on Player Names 
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2.3 Entering Names 

 
 

Names can be entered by typing them in full, typing the 4 character code if you have set this up, the 

NBO Number or by selecting the name from the database by clicking on it.  The list on display can be 

reduced by clicking on the appropriate letter at the bottom of the screen – only surnames starting with 

that letter then appear in the right-hand screen. 

To delete a name you have entered, click on that cell and press the <Del> key. 

It is also possible to cut & paste names that have been entered; left click to select name, right click to 

cut, left click on destination cell, right-click to paste. 

Another way of entering the names is to import them from a csv file prepared in the format shown 

below (names in pair number order) 

 

 

When finished with the names entry> OK > Event Menu 
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3. ROUND 1 SETUP 

 

3.1 Finalising the Event 

From the Event Menu > Assignments > Assignment screen: - 

 
 

3.2 Missing Pairs 

Click on the Missing Pairs tab. 

If a pair is missing or leave they can be removed from the event by clicking on their name 

entry in the left-hand screen.  That pair is then moved to the right-hand screen.  If you have 

selected the wrong pair, click on their entry in the Missing column and they are restored.  If 

are going to have a  half-table throughout it is normal to have the highest pair number (NS at 

T1) as the missing pair.  

Click on the Assignments tab to return to that screen. 
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3.3 Permanent Half-table 

If you are going to have a half-table throughout the event, it is worthwhile making some 

changes to the set-up. 

Form the Assignments screen click on Return > Event Menu > Event Details > Movement 

Details tab 

 
 

Because you had 7.5 tables you had to set the event up as 8 tables.  Consequently, the 

program will factor all X-IMP scores by 8/7 (expected scores/actual scores on each board). 

Similarly if you had chosen X-IMPs / comparisons the program would factor up by 8/7 then 

divide by 8 (the number of expected comparisons).  Yet again if you were scoring by X-

IMPs/sqrt (rc/2) where r is the expected scores & c the expected comparisons, the program 

after factoring up by 8/7 would then divide scores by sqrt (8 x 7/2). 

You can avoid all this factoring by setting the Table Override to 7 

 
 

Now the program is expecting only 7 scores (6 comparisons) on each board – so no factoring 

up. 

If scoring in X-IMPs / comparisons, the program would now simply divide the X-IMPs by 6 

and if scoring in X-IMPs/sqrt (rc/2) where r is the expected scores & c the expected 

comparisons, the program would simply divide the X-IMP scores by sqrt (7 x 6/2). 

 

Click OK > Event Menu > Assignments > Assignments screen 
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3.4 Draw for Round 1 

 
Ensure Current Round & Danish are selected and that the other options are as shown 

above (these settings should remain as default for the rest of the event) and then click on  

Do Round 1 Draw > Message appears > OK. 

Pairs are assigned in the normal ‘Swiss’ pattern with pairs 1 & 2 sitting NS & EW resp. at 

T1, and so on: - 

 

 

 

 

 

The next stage is to edit this draw so that it corresponds to 

the line-up for round 1 in the movement you are using. 

With 8T we should have pr 16 at T1 NS and pr 1 as EW 

 

Click in the box for NS at T1, type 16 then click in the EW box for T1 and type 1.  Continue 

this process until all the tables have been re-assigned 

 

 

The draw should now look like this 

 

Click on the Set Manual Assignments button (bottom 

left) > Message > Yes 

 

Now click the Return button (bottom right) 

Any missing pair should be entered with pair number 0 
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You are returned to the Event Menu 

3.5 REPORTS SET-UP 

Reports are accessed from the Event Menu by clicking Reports - 

Check that Output To is Notepad then click on the Printer Settings tab: - 

 
Ensure that the Default Printer is correct (drop down list to change it) and that the other 

details are as shown above. 

To change a font or size of font, click on the report type, eg Ranks.  Make changes as 

appropriate then click OK.  To change the Orientation select from the drop-down list.  Once 

the settings have been made they should remain the same unless you change them. 

When finished, click the Return to Display Reports button > Reports screen > Return 

button (bottom right) > Event menu 



  

Oct 2013 

  11 

4. BRIDGEMATES 

 

4.1 Check settings on Bridgemates & Server 

Bridgemates 

Press OK to get to the initial Bridgemate II screen.  SETUP should be displayed (bottom 

left).  Press the button below SETUP and check that each bridgemate is set to Section A, the 

correct Table and Channel.  If working in a club’s premises I recommend setting the channel 

to 3 –some clubs leave their bridgemate server switched on (usually channel 0 or 1). 

To change any of above settings, use the up/down buttons to get to the correct item then, use 

the + and _ keys on the bridgemate to increase/decrease the setting.  When finished, press the 

BACK button > initial screen. 

Server 

Attach the server to the computer (USB) then start BridgeMate Control Software (BCS). 

On the Menu Bar at the top of the page select Server > Channel selection.  If the channel is 

set correctly > Close.  To change the channel, select the desired Channel from the drop-down 

list > Set > OK > Close. 

Finally, close down BCS via File > Exit 

 

In the scoring program, navigate to the Event Menu > BridgeMate Scoring and select the 

BCS Admin tab 

 
If using Windows 7 the BCS program path should be as shown above.  In XP the path is 

C:\Program Files\Bridgemate Pro\BMPro.exe.  If the correct path is selected then the version 

number should be visible.  If path is not correct (in which case BMPro will not launch) then 

click on the blue Set BCS Program and then navigate as appropriate to the correct location 

depending on whether you are using XP or Windows 7.  Once set the path will not alter of its 

own accord.
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5. ROUND 1  

 

5.1 Starting the Bridgemates 

From the Event Menu > BridgeMate Scoring 

 
 

Ensure Session = 1 & Section = All (or A) are displayed (top right of screen). 

Click Create Database.  Reset Server box should now be ticked and Launch BCS button 

should be active – but don’t click on it yet!! 

 

Now click on Set BCS Options at the bottom of the screen 
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Set up as shown above (format of previous results does not matter). 

Now click on the Extra Options for BM2 tab 

 

Set up as shown above.  When finished click the OK button (bottom right) > Results screen 

If you want to display player names at the start of each round see Appendix 2 

Click Launch BCS > Message > Yes. 

Bridgemate Control Software now opens showing all the tables with a red status circle.  Once 

the bridgemates are started at the tables this will change to green. 

There are various ways of monitoring the progress of the event.  Personally, I find it easier to 

do it using BCS.  Minimise the scoring program and select the Round Monitor tab in BCS.  

This displays the number of scores received from each table. 

Once all the scores are in for Round 1, restore the scoring program which should be at the 

Bridgemate Scoring screen on the Results tab with all results from round 1 in. 
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The next two tasks are: - 

 a) Produce the round 2 draw and send to bridgemates 

 b) Produce print-outs for round 1. 

If there is plenty of time between rounds you could do the print-outs first but my inclination 

is to get the round 2 draw out to the bridgemates first of all then do the reports 

 

5.2 Round 2 Draw 

From the BridgeMate Scoring screen click the Return button (bottom right) > Event Menu. 

Select Assignments 

There should a message at the top of the screen saying “Round 2 awaiting Assignments over 

all Sections. 

Click Do Round 2 Draw button > OK.  The program will have do a ‘Danish Swiss’draw, so 

amend the draw by typing in the line-up for round 2 in the movement (in this case; T1; 16v2;  

etc. and when finished click Set Manual Assignments button > message > Yes 

Setting the draw as Danish is to avoid the problem that some users have encountered in that 

towards the end of a barometer event, the program could  not perform a new ‘Swiss’ draw.  

The solution to this was to select Danish and try doing the draw again, then amend as usual 

followed by Set Manual Assignments 

Setting the draw as Danish throughout should hopefully avoid this problem.  

Click Return button (bottom right) > Event Menu > BridgeMate Scoring 

On the BridgeMate Scoring screen check Update Movement button shows Round 2 then 

click Update Movement button > message > Yes. 

If a report should now appear in BCS > Close 

Round 2 data is now sent to the bridgemates 



  

Oct 2013 

  15 

6. REPORTS 

 

Note: Many of the reports have many options – worthwhile clicking Printer Preview button 

to see what the report would look like before actually printing.  A dotted line in the 

Printer Preview display indicates a page break.  To close the preview click on the red 

X in the top right-hand corner; you are returned to the Report screen 

6.1 Ranks 

Select Ranks from the list in the Print Menu on the left-hand side of screen 

Ensure that the correct round is displayed in the Round box (right-hand side of screen) 

In the Print Options section, select Ranks + Latest Match Score & Ranks in Pair Order 

To print, click Send To Printer button; you need 2 copies (one for display & the other for 

scorer), so click that button again. 

This report list the pairs in pair number order, displaying pair numbers, names, Total X-IMPS 

and X-IMP score in the round (match) just played.  It is the values in this column that are 

typed into the spreadsheet. 

WARNING 

Players should be made aware that the printouts from the scoring program have not been 

capped so round totals, event totals and ranking may not be accurate. 

 

6.2 Travellers 

Select Travellers from the list in the Print Menu on the left-hand side of screen 

Ensure that the correct round is displayed in the Round box (right-hand side of screen) 

Leave all options in the Print Options section, unticked. 

Click Send to Printer button 

 

6.3 Table Check Slips (Optional) 

The warning re ranks print-out also applies to the check slips. 

If you do decide to print & issue, select Collated (Guillotine) & Exclude Leader Info in the 

Print Options section 

Normally, you would print the table check slips for the round just ended once the draw for the 

next round has been made; eg, assign for round 2 and then print round 1 check slips.  This 

way the slips have the pairs at their assigned table in round 2 

Occasionally at the end of a session or the end of the event you may wish to print the check 

slips before the next round has been drawn – in which case, select all the options in the Print 

Options section 

If the option Collated (Guillotine) is ticked, then the check-slips are printed with table 1 at 

the top of page 1, table 2 at the top of page 2 … Then, if you have a powerful enough 

guillotine the whole stack of check-slips can be sliced to give 4 or 5 piles with the tables in 

numerical order. 

If the option Collated (Guillotine) is not ticked, the check-slips would be printed out with, 

for example, tables 1-5 on page 1, 6-10 on page 2 … 

 

It is also possible to print out a check-slip for a selected pair – use the drop-down menu in the 

Print Options section to select 

When printouts are complete, click Return > Event screen > Bridgemate Scoring. 

 

Note: 

If an event has 10+ boards/round or 15+ rounds, the check slips report will no longer print 

out side by side.  In such cases, select the option One per Row 
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7. ROUND 2 ONWARDS 

From now until you reach the end of the Session, the procedure for Round 2 and subsequent 

rounds is simply a repeat of the procedures described above for rounds 1 & 2: - 

Once all the scores for a round are in, do the draw for the next round, amend it to the line-up 

you require, update the movement thus sending the new round data to the bridgemates and 

then produce the print-outs for the round which had just ended 

 

 

8. SESSION 2 (and the start of any subsequent sessions) 

Once all the scores are in for the last round of Session 1(round 8 in this example) print out the 

reports for that round > Return to get to Event Menu > Exit Event > Event History screen. 

Close BCS via File > Close > File > Exit 

From the Event History screen, select the “Multi” Section (Master Control Event) > Retrieve 

Event > Event Menu > Assignments. 

Current Movement State will show display message similar to “Round x awaiting 

Assignments over all Sections (New Session) 

> Do round x Draw (for first round of new session; round numbers are carried forward from 

session 1) > amend the draw > Set Manual Assignments button > Return button > Event 

Menu > BridgeMate Scoring 

Session box (top right-hand of screen) should display session as 2 

Create Database button > ENSURE Reset server box is ticked > Launch BCS + Start 

Receiving button > message > Yes  

BCS opens and tables are added to the server.  The rest of session 2 is simply a repeat of 

session 1. 

 

 

8. END OF EVENT 

 

Reports for publication on the Internet 

Any reports can be produced in Web format by selecting Web Table in the Output To 

section of the Reports screen.  With that option selected click the Display on Screen button.  

Report appears; if OK, now click the Save button.  Give the file an appropriate name, choose 

desired location > Save > close report (click on X in top right-hand corner). 

If printing the travellers for the event it is possible to produce one file for the whole event by 

selected Unused in the InSession box and All in the Round box.  Alternatively by selecting 

1 in the InSession box and ALL in the Round box a file for all hands in session 1 are 

produced.  Similarly files for individual rounds could be produced. 

Another alternative is to select EXCEL (XLS) File rather than Web Table in which case a 

spreadsheet is produced rather than a htm file.  The spreadsheet is easier to edit if that is 

required. 

 

After the last round of the event has been played and all the scores are in, print out the reports 

and then Return button > Event Menu > Exit Event > Return to Main Menu button > Exit 

Close Bridgemate Control Software via File > Close > File > Exit 



  

Oct 2013 

  17 

9. SCORE AMENDMENTS 

 

If the bridgemates collapse scores can be entered manually.  Navigate to the Event menu 

(usually click the Return button and then select Enter Scores).  The same screen is used for 

any score amendments.  If you do have to enter amendments they are best left until all the 

scores for that round have been received. 

 
PS – don’t worry about the disparity in the scores shown above – I used a utility which 

produces random scores to save me entering them manually via the bridgemates 

 

Using the boxes at the top of the screen, navigate to the correct Session, Section, Round and 

Table. 

Details of score input operations can be displayed by clicking Result Input Methods.    

 

9.1 Delete a score 

To delete a current score, click in the appropriate box in the Score column and press the ‘D’ 

key (case does not matter) – the score is deleted. 

9.2 Replacing one score with a different score 

With the Contract/Result Entry box unticked, click in the box and either enter the score as 

e.g. 10+ or 9- <Enter>.  Alternatively, if so inclined, you could tick the Contract/Result 

Entry box and enter the contract details according to one of the formats described in Result 

Input Methods followed by <Enter>. 

9.3. Replacing a score with an Arbitral score. 

Click in the box and enter the score as 50/50, 40/60 etc. followed by <Enter> 

9.4 Board needs to be arrow switched 

This could be because a table has played a board the wrong way round or because the 

movement requires that some of the boards are arrow-switched 

Click in the box in the Score column and type A. 
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9.5 Weighted Score 

A weighted score can also be entered (may be assigned either by TD or Appeals Committee).  

As an example, lets say the weighted score is (all scores from NS perspective): 

25% of +1430 

40% of +680 

20% of +650 

15% of -100 

To enter this in the scoring program, click in the appropriate cell in the Score column for teh 

session, round, table, board - selected cell should be yellow > press D to delete any previous 

entry then enter as follows in the weighted boxes 

% NS Score To 

25 1430 Both 

40 680 Both 

20 650 Both 

15 -100 Both 

 

Now press W with the cursor in the yellow cell to enter the score. 

You may display it at any tome with the S command (Result Input methods for all scoring 

commands). 

 

Split scores (weighted or not can also be entered. 

For example: - 

50% of +400 to NS 

50% of -50 to NS 

100% of -400 to EW 

 

Enter as follows 

% NS Score To 

50 400 NS 

50 -50 NS 

100 EW Both 

 

Now press W with the cursor in the yellow cell to enter the score. 
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Movement Set-ups    Appendix 1 

 

3 Tables 20 bds/rd 

Day 1  Session 1: 3 rounds; bds 1-60 

Day 2  Session 2: 2 rounds; bds 1-40 

 
Duplicating Requirements 

 Day 1: 1 set of 1-60 dealt as 1-32 + 1-28 

 Day 2: 1 set of 1-40 dealt as 1-32 + 1-8 

 

4 Tables 16 bds/rd 

Day 1  Session 1: 4 rounds; bds 1-64 

Day 2  Session 2: 3 rounds; bds 1-48 

 
Duplicating Requirements 

 Day 1: 1 set of 1-64 dealt as 1-32 + 1-32 

 Day 2: 1 set of 1-48 dealt as 1-32 + 1-16 

 

5 Tables 14 bds/rd 

Day 1  Session 1: 3 rounds; bds 1-42 

  Session 2: 2 rounds; bds 1-28 

Day 2  Session 3: 4 rounds; bds 1-56 

 

 
Duplicating Requirements 

 Day 1: 1 set of 1-42 dealt as 1-32 + 1-10 + 1 set of 1-28 

 Day 2: 1 set of 1-56 dealt as 1-32 + 1-24 
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6 Tables 12 bds/rd 

Day 1  Session 1: 3 rounds; bds 1-36 

  Session 2: 3 rounds; bds 1-36 

Day 2  Session 3: 5 rounds; bds 1-60 

 
Duplicating Requirements 

 Day 1: 1 set of 1-36 dealt as 1-36 + 1 set of 36 dealt as 1-36 

  (If 36 bd sets not available, then 1-32 + 1-4) 

 Day 2: 1 set of 1-60 dealt as 1-32 + 1-28 

 

6 Tables 10 bds/rd 

Day 1  Session 1: 6 rounds; bds 1-60 

Day 2  Session 2: 5 rounds; bds 1-50 

 
Duplicating Requirements 

 Day 1: 2 sets of 1-60 dealt as 1-32 + 1-28 

 Day 2: 2 sets of 1-50 dealt as 1-32 + 1-18 

 

7 Tables 10 bds/rd 

Day 1  Session 1: 4 rounds; bds 1-40 

  Session 2: 3 rounds; bds 1-30 

Day 2  Session 3: 5 rounds; bds 1-60 

 
Duplicating Requirements 

 Day 1: 2 sets of 1-40 dealt as 1-32 + 1-8 + 2 sets of 1-30 

 Day 2: 2 sets of 1-60 dealt as 1-32 + 1-28 
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7 Tables 8 bds/rd 

Day 1  Session 1: 7 rounds; bds 1-56 

Day 2  Session 2: 6 rounds; bds 1-48 

 
Duplicating Requirements 

Day 1: 2 sets of 1-56 dealt as 1-32 + 1-24 

 Day 2: 2 sets of 1-48 dealt as 1-32 + 1-16 

 

8 Tables 8 bds/rd 

Day 1  Session 1: 8 rounds; bds 1-64 

Day 2  Session 2: 7 rounds; bds 1-56 

 
Duplicating Requirements 

Day 1: 2 sets of 1-64 dealt as 1-32 + 1-32 

 Day 2: 2 sets of 1-56 dealt as 1-32 + 1-24 

 

9 Tables 8 bds/rd 

Day 1  Session 1: 5 rounds; bds 1-40 

  Session 2: 4 rounds: bds 1-32   

Day 2  Session 3: 8 rounds; bds 1-64 

 
Duplicating Requirements 

 Day 1: 3 sets of 1-40 dealt as 1-32 + 1-8 + 3 sets of 1-32 

 Day 2: 3 sets of 1-64 dealt as 1-32 + 1-32 
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9 Tables 6 bds/rd 

Day 1  Session 1: 9 rounds; bds 1-54 

Day 2  Session 2: 8 rounds; bds 1-48 

 
Duplicating Requirements 

 Day 1: 3 sets of 1-54 dealt as 1-32 + 1-22 

 Day 2: 3 sets of 1-48 dealt as 1-32 + 1-16 

 

10 Tables 7 bds/rd 

Day 1  Session 1: 5 rounds; bds 1-35 

  Session 2: 5 rounds: bds 1-35   

Day 2  Session 3: 9 rounds; bds 1-63 

 
Duplicating Requirements 

 Day 1: 3 sets of 1-35 dealt as 1-35 + 3 sets of 1-35 dealt as 1-35 

  (If 36 bd sets not available, then 1-32 + 1-3) 

 Day 2: 3 sets of 1-63 dealt as 1-32 + 1-31 

 

10 Tables 6 bds/rd 

Day 1  Session 1: 10 rounds; bds 1-60 

Day 2  Session 2: 9 rounds; bds 1-54 

 
Duplicating Requirements 

 Day 1: 4 sets of 1-60 dealt as 1-32 + 1-28 

 Day 2: 4 sets of 1-54 dealt as 1-32 + 1-22 
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Displaying Player Names on B’mates      Appendix 2 

 

 

1. Enter player names for the event 

 

2.  Create Database then when setting the Extra Option for BM2, ensure that the entries 

for Player Names and Name Source as set as shown below 

 
Clicking OK takes you back to the Results tab 

 

3. Now click on the Names tab 

 
Now click on Write Names to BCS 

Message > Yes > OK 

Above screen will now be populated with the player names and at the same time the names 

are sent to the BCS database file which will send the names to the b’mates. 

 

Click on Results tab to get back to that screen 

Now click Launch BCS / Receive Results 

 

Process described in step 3 has to be repeated at the start of each new session. 


